1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Note: All passwords have been invalidated, please use Lost Password to create a new password. More info...
    Dismiss Notice

Done AG+ modpack files

Discussion in 'Other' started by jayjayx5x1, Feb 9, 2022.

  1. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    I deleted the mod folder when trying to force update through the launcher without backing them up. (had what was a launcher issue, but thought it was a pack issue).

    So since it isn't downloadable through the launcher anymore, kinda can't play it.

    Wondering if there is anyone, or anywhere I can get the mod-pack from.
     
  2. wyndman

    wyndman Well-Known Member

    Messages:
    4,043
    Likes Received:
    2,014
    Local Time:
    8:55 PM
    I would like to think we still have them on a floppy disk somewhere, let me summon @Administrator to see if they can help you out.
     
  3. HanoverFist69

    HanoverFist69 Administrator Patron Tier 3 Booster

    Messages:
    1,688
    Likes Received:
    795
    Local Time:
    5:55 PM
    We dont have any backups of that on the servers anymore. Maybe @SirWill has one laying around though?
     
  4. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    I have two or three old computers I can check to see if I have the client files…

    Edit: Found it, but it is a tarball of .minecraft. I will try to experiment with which Java and which forge its suitable for (6.4.50.1,345 ?) in MultiMC. So far mine just crashes with JDK 1.7_80 and 1.8_281. ArrayIndexOutOfBounds on armorstatushud, so I might have to try 1.8_140-something.

    Edit2: Ah, found the MYM instances folder for it on 2! computers. I've really gotten around. testing it now.
     
    Last edited: Feb 18, 2022
  5. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    Thanks, it is a really big help.

    And going the extra step to test it is more than I could ask for, so thank you ^_^
     
  6. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    OK, so…

    No matter which java version I use I get

    Code:
    java.lang.ArrayIndexOutOfBoundsException: 0
    	at bspkrs.util.ModVersionChecker.<init>(ModVersionChecker.java:62)
    which in short appears to be a buggy bug in the library used by both StatusEffectHUD and ArmorStatusHUD and is probably a result of the code checking the versions. The same libraries, mods and Forge version are used in Crash Landing where they don't cause the same crash - ironic isn't it. Crash Landing doesn't Crash Land. So I need to figure out what config to change so that it doesn't run that check.
     
  7. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    And right off the bat we have a winner:

    bspkrsCore.cfg:
    Code:
    	# Set to true to allow checking for updates for ALL of my mods, false to disable [default: true]
    	B:allowUpdateCheck=false
    Changed from true to false and the pack loads like a wonder. Would you like a dropping drop-in .minecraft folder for the gym mym launcher or do you prefer MultiMC? I'll just clean up the folder so you don't get all my IDs :D


    (I need to turn off this autocorrect ASAP)
     
  8. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    So… Just dropping the AgSky+ folder doesn't help. The launcher insists on checking for an update, which it obviously can't find and then refuses to launch, even when I turn off update checking in the client GUI. That brings us back to MultiMC, which requires you to create an empty instance of MC 1.6.4 in MultiMC and install Forge version 9.11.11345 before dropping in the files in the minecraft folder.

    Edit: But after some more testing I was able to find that there are two library files you need to add to libraries:

    mineyourmind/libraries/net/minecraftforge/minecraftforge/9.11.1.965/minecraftforge-9.11.1.965.jar
    mineyourmind/libraries/net/mineyourmind/mojang/launchwrapper/1.8c/launchwrapper-1.8c.jar


    In addition there was a two values I had to change in
    instances/MyM-FTB-Agrarian_Skies+/instance.json
    I had to set them to "updatePending":false,"installed":true .

    I would still need a heads-up so that I know when to make the files available.
     
    Last edited: Feb 24, 2022
  9. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    Launcher-side issues are no problem, since i have both curse and multimc, so I can use either of those if needed.

    If you are able to, having both would be nice ;P But multiMC is the preferred. (read your comment about it after the first part of this reply)

    Honestly am happy with w/e as long as I can play it again XP
     
  10. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    Here are the files:

    GoogleDrive

    The main zip file is the pack, as it was snitched from the mineyourmind instances folder (but with my ID and such deleted). I included the jar files that needs to go into the libraries folder as described over.

    Note that this does not include a starter island. I made one by starting a new world as creative and placing some blocks, then copying the region files over. Then I found

    Agrarian Skies Map Backup (curseforge)

    It complains about missing blocks and wrong IDs, but when I run it, it works. The islands has nodes and look more or less like the original island.
     
    Last edited: Feb 24, 2022
  11. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    Map stuff is fine, i have my own save :)

    As for getting the pack to run... uhhh, I have no idea where to find the mineyourmind/libraries/net etc. Am using windows and well isn't in appdata.

    Tried to use multiMC but well crashes XS gonna fiddle with it for a bit.
     
  12. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    "2022-02-25 13:31:05 [SEVERE] [ForgeModLoader] Unable to launch



    java.util.ConcurrentModificationException

    at java.util.ArrayList$Itr.checkForComodification(Unknown Source)

    at java.util.ArrayList$Itr.remove(Unknown Source)

    at net.minecraft.launchwrapper.Launch.launch(Launch.java:114)

    at net.minecraft.launchwrapper.Launch.main(Launch.java:27)

    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

    at java.lang.reflect.Method.invoke(Unknown Source)

    at org.multimc.onesix.OneSixLauncher.launchWithMainClass(OneSixLauncher.java:210)

    at org.multimc.onesix.OneSixLauncher.launch(OneSixLauncher.java:245)

    at org.multimc.EntryPoint.listen(EntryPoint.java:143)

    at org.multimc.EntryPoint.main(EntryPoint.java:34)

    Process exited with code 0."

    This is where it crashes on MultiMC. befoere the are a bunch of warning about "does not have a MCVersion annotation" but they seem to not be part of the cause.

    Only other note-able one is this "2022-02-25 13:32:47 [INFO] [STDERR] Warning: version of ForgeMultipart-universal-1.6.4-, 1.0.1.268 is newer than request 1.0.0.244"
     
  13. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    its in AppData\roaming\mineyourmind

    og you just type %appdata% you get AppData\local\ which is the wrong spot.

    To get MultiMC to run it you need to create an instance of 1.6.4 as mentioned above with forge 9.11.1.965 (!) and then you just copy the contents of the Minecraft folder from the zip, replacing mods, config etc.

    Probably the most important thing to remember though is to make sure you have an “old” java for that instance and not 1.17.

    I fixed all the stuff in config, like bskrCore.conf that made the game crash and I now have the pack running in the MyM launcher and MultiMC on an old MacBook, a new M1 MacBook (aarm64) and on a Windows box.
     
    Last edited: Feb 25, 2022
  14. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    %appdata% takes me to roaming, and I only have a .mineyourmind folder there, where the instances are. can't seem to find a mineyourmind folder that has other wise (checked all the folders, local, locallow, and roaming.), and the .mineyourmind only has temp and launcher, with launcher having a single .jar file.

    As for the multiMC, where do you put the forge file? since mod folder doesn't seem to be the right place. And choosing the same forge version doesn't seem to work.

    On the java thing, I have it using 1.8.
     
  15. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    update: I got it working.

    I just took an normal agrarian skies instance in curse, and copypasted AG+ and deleted dupe mods. (and the dupes that forge would always update... it didn't like extrautil version e, it wanted b.)

    No Menu music, or the classic menu tho.... sadge.
     
  16. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    Thats from options… On one of the copies I made, I deleted the options file here when I managed to select esc as the key for galaxy map, instead of M since I wanted M to be the minimap.

    You are right BTW about AppData. .mineyourind is in Roaming, so the full path to the launchwrapper should be:

    C:\Users\<username>\AppData\Roaming\.mineyourmind\libraries\net\mineyourmind\mojang\launchwrapper\1.8c\launchwrapper-1.8c.jar

    Same with forge, that should be placed in
    C:\Users\<username>\AppData\Roaming\.mineyourmind\libraries\net\minecraftforge\minecraftforge\9.11.1.965\minecraftforge-9.11.1.965.jar

    From 1.7 and upwards they moved forge to
    C:\Users\<username>\AppData\Roaming\.mineyourmind\libraries\net\minecraftforge\forge\



    On MultiMC you do not place the forge file anywhere, you create an empty vanilla 1.6.4 instance, then use the button that say install forge. See this YouTube video for a better explanation on how to manage forge and mods in MultiMC :

    ScottoMotto YouTube
     
  17. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    yeah this is where it gets weird, the only folders I have in the .mineyourmind is instances, temp, and launcher.
    Maybe I have to sucessfully launch a pack first, I dunno. (will test it out)
    As for the multiMC thing, I did it like that, it just doesn't like something and won't boot.

    But I got it working at least so yay :D Is what matters.

    So tyvm for the help, and the files. Now i can keep playing.

    Although if I did want to restore the menu and the gui as it is on mym, how should I go about doing that?

    edit: yeah... launching something made the files exist
     
    Last edited: Feb 25, 2022
  18. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    My guess, now that I don't have the pack in front of me, is that you can set this in the options file. But again, that isn't something I have looked into.
     
  19. jayjayx5x1

    jayjayx5x1 Well-Known Member

    Messages:
    38
    Likes Received:
    0
    Local Time:
    10:55 AM
    Hmmm, so I did everything for the Mym launcher, but it still says needs update required, but no longer avaliable.

    (and i changed the instance.json file, also made sure to uncheck the download modpack updates.)
     
  20. Willfon

    Willfon Moderator

    Messages:
    426
    Likes Received:
    106
    Local Time:
    2:55 AM
    This is the same error that I got, but I had to set both
    to false and
    to true .

    Oh! Right! And that was after I had placed the library files mentioned in the correct place. It will notice that the library files are missing and tag updatePending to true again, so that you will have to go back and reedit.

    So first replace the library files, then edit instance.json.
     

Share This Page